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Preface

This document includes all public ImageCapture Documentation that is currently available in
English. This is specifically not intended to be viewed as a comprehensive ’User Manual’ that
describes each setting in detail; it should be viewed as general documentation divided into the
following complementary parts:

I Product Specialist

II End User
A brief reference for the end user.

III Application Manager
All the information required to carry out the role of applicationmanager, e.g. all require‐
ments concerning installation, database management, licenses, etc.

Please let us know if you have a suggestion for the addition, deletion or modification of this
documentation to help us improve it. We are particularly interested in feedback from part‐
ners, application managers and end users so that we can understand what is good about the
documentation and how things can be better described.

Scan Sys B.V. <info@scansys.nl>

February 2, 2021

This documentation describes ImageCapture 8.18 and is dated February 2, 2021. Separate
PDFs are available for reading on screen or for double‐sided printing. The latest versions are
available through our Partner Portal: http://www.scansys.eu
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Chapter 1

Templates

Subjects in this chapter:
• Configuring templates
• Regular expressions

ImageCapture will, in many cases, recognize data from an invoice completely automatically. If
this is not the case, for example when the invoice does not have a “tidy” layout, templates can
be used to improve recognition. In this chapter the various options are explained.

1.1 Creating
In Section 5 you will find an explanation of how a template can be created from the Client. In
this case, the selected relation is linked to the template. It is also possible to create a template
in the Manager. In this case, the relation belonging to this template needs to be chosen in
a pop‐up screen and the associated invoice needs to be imported manually. In both cases
it is important that the invoice used is typical of all invoices that are to be processed using
this template. This is especially important if templates are to be used to distinguish different
invoice layouts for the same relation.

1.2 Configuring
Template configuration can only be done using the ImageCapture Manager. It can be done by
Admin users via the relevant class on the Classes tab, but only when no users are active in this
class in the Client. Both Admin users and Template users can configure templates using the
Templates tab. In this case, other users can continue to work in the Client.

On the Templates tab you first of all select the class for which you want to configure templates.
You will then be shown the list of existing templates. Each template has an icon that shows
what the status of the template is:

New The template is newly created, but not yet configured.
Complete The template has been fully configured in the Manager.
Modify The template is already fully configured, but a user has indicated that something

needs to be amended.
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Inactive The template has been set to inactive, for example because it is only partially config‐
ured and in this stage will make recognition worse.

When you select a template, you are shown the invoice which was used to create it. Directly
below the name the status is displayed and you can change it, for example, when you have
finished configuring and want to change the status from New to Complete. When a message
has been entered by a user for this template, it will be displayed in the yellow bar above the
invoice.

To the right of the invoice you have the option to continue configuring the template. The
following paragraphs describe the different options.

1.2.1 Identification
ImageCapture normally automatically identifies which relation the invoice belongs to, based
on the data in the underlying administration. If this automatic recognition does not work, then
that link can also be created on the basis of other values present on the invoice.

In addition, the identification settings can be used to distinguish between different invoice
layouts for the same relation. This differentiation needs to be made using a unique value for
each layout.

Configuring the identification is done on the Identification tab. The following identification
methods are available:

Checksum This relates to values that can be validated, such as an IBAN, which includes a con‐
trol digit.

Field This is used if the relation (code) is already stored in a field, for example when importing
the invoice metadata from an XML file.

Numeric This relates to numeric values with no further validation. Take into account that the
selected value must be unique to this relation. So be careful about using small numbers,
because the PO Box number for a relation could also exist as part of the phone number
of another relation.

String This relates to one ormore text values. Using the Retain identifier order option, you can
define that the values must occur in the sequence given. Set this option, for example,
when you use the content of an address block (street, postal code and city) as values.

The values for the various identification methods can, just like fields in the Client, be read
by drawing a frame around them using the mouse while pressing the Shift key. For string
identifications, several lines can be read at the same time.

Using the Match option under the list of identification methods you can define whether the
template should be linked if at least one of themethods results in a match or only if all of them
do.

Use All, for example, if you want to distinguish different invoice layouts. For each template
you can then use the same bank account number for this relation and then define a unique
text value for each template. A document is then only linked to a template if both the bank
account number and the unique value are found.

Any can be used, for example, if a relation sometimes shows one bank account number and
sometimes another on their invoices. You can provide both values as Checksum values and the
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document will be linked to the template if (at least) one of the values occurs.

1.2.2 Improving reading field values
Using the Fields tab, the settings of one or more fields can be changed. These changes then
only apply to documents that are linked to this template. For example, reading an invoice
number can be corrected, if the automatic recognition does not do it properly, by dragging a
zone where this value should be searched for and/or adding a different keyword.

Zones

On the Fields tab in the top right of the screen all present Smart Fields are shown. KeepDisplay
all Field types disabled for this. After selecting a field in the list it is possible to draw one or
more zones for that field using the Field zone button in the button bar above the invoice. This
ensures that values will only be read if they are partially or fully inside that zone. For each
zone you can define to which pages it applies. The zones for the currently selected field, which
are shown in blue, show this value in the top left of the zone. This can be changed by first
choosing the mouse arrow button from the button bar, selecting the zone using a right mouse
click and then choosing Pages/Order/Group/Anchor. See Table 1.1 for some examples of how
to configure these pages.

Table 1.1: Configure pages to be used

Setting Pages used

1,3,5 Pages 1, 3 and 5
1,n Page 1 and the last page
1,4-n Page 1 and page 4 up to and including the last page
* All pages
*,-n All pages except the last one
n-1 Only the second‐last page

For fields where the values are found using keywords, such as invoice number (Invoice Number
Smart Field), the size of the zonewill affect the behavior. Initially searching is done by keyword.
If no value is found this way, the full OCR value of the zone is used as the value. This is only
done, however, if the zone is small enough. If the zone is too large to be able to fall back on
the full OCR value then its outline will turn red.

To avoid the zones being read out incorrectly, for examplewhen it varies howhigh the invoice is
printed on the page, it is advisable to create extra zones using the Alignment zone button. This
type of zone helps to make sure that an invoice is correctly repositioned, if necessary, before
values are extracted. This is necessary mainly for invoices that at some point in the process
have been scanned. Invoices that are received digitally usually come directly from a financial
system and then often have identical positioning.

When using alignment zones, 3 or 4 zones need to be drawn around characters or symbols
in the invoice layout, which are the same for every invoice. They need to be pieces of data
that are not pre‐printed on the form that is used, but that are printed at the same time as the
invoice data, and therefore move the same distance as the data. For best results, do not make
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these zones too large. The best result is achieved by picking a short word, or even just a few
letters, so long as the value that is used does not occur several times close to each other. If
this is not the case, then a message is displayed and a different zone needs to be selected.

Settings

When selecting a field from the list of fields in the top right of the screen, all the settings for
that field are shown below the list. These settings are organized into a number of groups that
depend on the field type. By default, the checkbox Use defaults is enabled for each group.
This means that the settings at class level are applied. If this checkbox is disabled, the settings
below can be changed so that the field behaves differently just for this template. The following
groups may be present:

General These are general settings, such as the default value that the field should get for
documents linked to this template.

Smart Search/Additional Here settings for extracting values can be adjusted. This group is
explained in more detail below.

Validation Here different validation settings can be entered. These are not used to read values,
but are only used when verifying.

Interactive/Zonal OCR These settings are used if the full OCR of the zone is read, or if interac‐
tive OCR is used during verifying in order to read the value at that stage. For example,
you can set the language here so that characters of non‐Western languages can be read.

The most commonly used options in the Smart Search group are the following:

Read value This determines whether the field is to be read automatically or not.
Custom keyword Use this to enter a different keyword. When a relation prints the invoice

number as “Purchase number: 12345” you can enter the term “Purchase number” here
in order to read the value 12345. The colon does not need to be entered. Other separa‐
tor symbols, like a period after an abbreviation do need to be entered.

Only search under keyword Use this option, for example, if the invoice number is printed be‐
low the word “Invoice number” and a value that is to the right of the word “Invoice
number” is being read instead.

Use Regex filter Use this option to only use the values that are found if they match a defined
format. See Section 1.5 for more information about regular expressions.

Line recognition

Often invoices include data in the formof lines or rows. For example, a list of individual ordered
items or number plates on a lease invoice. To read these lines, a number of specific field types
can be used. Configuring this is more complex than extracting header fields, especially if more
than two columns need to be read out. In such cases, it is best to first attend a template training
course by Scan Sys.

The following field types are used for line recognition:

Amount Line Field This field is used for amounts and is named rAmount, for example.
Text Line Field (character) This field is used for text values, such as item numbers and is

named rItemCode, for example.
Text Line Field (memo) This field is used for text values existing of multiple lines, such as de‐

scriptions and is named rDescription, for example.
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For the fields that are used for line recognition, the option Read value is normally disabled
at class level. Reading these fields can then be enabled and configured per creditor in the
corresponding template.

The following principles are important when using line recognition:

• Values to be read in different columns may not overlap vertically, see Figure 1.1.
• There is always at least one field, which is leading for the creation of lines. Every value

that is read for this field results in one line. If a value for this field is not read, then a line
will bemissing in the result. If there are several leading fields, the values to be readmust
always be on the same line, otherwise empty values will be inserted. If there are two
leading fields, 2 lines will be created in the case of Figure 1.2, whereas 4 lines will be cre‐
ated in the case of Figure 1.3. Any non‐leading fields are referred to in ImageCapture as
body fields and always follow the leading fields. This prevents extra lines being created,
for example, for sub‐totals.

Figure 1.1: Values that overlap vertically cannot be read

Figure 1.2: Correct alignment when using 2 leading fields

Figure 1.3: Incorrect alignment when using 2 leading fields

In Figure 1.4 the item code is the field for which each value found should result in exactly one
line being created. To do this disable the optionUse defaults and enable the option Read value.
Also make sure the option Is body Field is disabled so that this is the leading field. It should
now be determined how values are to be found for this field. In this case, a regular expression
is entered that determines that the values must start with PA or CON‐, followed by 1 or more
digits, a dash and 4 characters of any kind. See Section 1.5 for more information about regular
expressions. In some cases it is now necessary to draw a zone to define where the values are
to be found. In this case we are talking about such a specific regular expression, that the values
cannot be read from the wrong place, so no zone is needed.
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Figure 1.4: Template configuration
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For each item code found, the quantity and the price per unit need to be read. To do this, dis‐
able the option Use defaults and enable the options Read value and Is body Field. ForMultiple
body value behavior select Use first value.

The rQuantityOcr field needs to be configured further. First a regular expression needs to be
entered. In this case we are looking for numeric values, with or without decimals. Because
this is a very general regular expression, you also need to draw a zone in which these values
are searched.

Finally, the rPriceOcr field needs to be configured. Because this is an Amount Line Field it will
automatically search for amounts and no regular expression needs to be entered. Because
there are multiple columns with amounts, a zone also needs to be drawn for this field.

When configuring body fields, Multiple body value behavior can be used to determine what
happens if for a value of a leading field multiple values are found for the current field, as in
Figure 1.5. The following settings are available:

Figure 1.5: Multiple body values per leading value

Use first value The first value is used.
Use last value The last value is used.
Use all values All values are used. For the second value to the last value an empty value is

inserted for the leading field.
Use all values, except the last one All values are used, except the final one. This can be useful

if the last value always is a sumof the values above. For the second value to the last value
an empty value is inserted for the leading field.

Concatenate multi‐line Merge all values with line breaks between each. This option can only
be used for a Text Line Field (memo).

Concatenate single‐line Merge all values with spaces between each.

For line fields, the Smart Search section has the option Allow overlapping matcheswhich influ‐
ences the search behavior. When three digit values are searched, for example, and the invoice
contains the value 1234, then only the value 123 will be found when this option is disabled.
When this option is enabled, then both 123 and 234 will be found as values.

1.2.3 Other settings
On the Smart Field Settings tab a number of extra options can be configured:
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Use default OCR pages / OCR pages These options determine which pages are used for ex‐
tracting field values. If the first option is enabled, then the value at the class level is
used. With OCR pages you can define a list of comma‐separated values, based, for ex‐
ample, on page numbers or range. See Table 1.1 for several examples.

Use dynamic language If this option is enabled, then the language to be used is defined based
on the country of the creditor or debtor in the underlying financial application. This
option only works if this function is correctly configured within the class. By disabling
this, you can force the use of a specific language, for example for a German creditor who
issues invoices in English.

Use default languages If this option is enabled, then the languages configured at class level
are used. By disabling this, you can select different languages in the list below for the
current template.

Use default VAT categories If this option is enabled, then the VAT percentages configured at
class level are used. By disabling this, you can select different percentages in the list
below for the current template.

On the Remove lines tab the removal of lines can be configured. The lines are only removed
temporarilywhile extracting data. The documentwill not be permanently changedby this. This
can be particularly useful for invoices where information is printed in a grid. In that case lines
can disrupt recognition, for example because a section of a line is read as a 1 or if a keyword
and its value are printed in separate cells. All values, except forMax wall percent, are defined
in pixels.

1.3 Testing
Settings can be tested during or after configuring a template. This can be doneusing the invoice
used to create the template or using files that are to be imported. You can do this by selecting
On Template… or On files… respectively in the Test Recognition menu. This starts the same
recognition process as in the Client.

Please note: when using Test Recognition → On Template… the result may differ from the
results of processing a document in the Client. There are two possible causes for this:

• The invoice from a template is always stored as a black and white image. This may affect
the recognition of text, for example, when text was originally on a colored background.

• The template does not keep the PDF text from the original invoice. This causes OCR to
be performed, which can give a different result to when using files containing PDF text.

On the Test results tab the result of the recognition process can be seen. The following infor‐
mation is displayed under Identification Job results:

Used pages The pages used for identification.
Matched Identification The name of the relation that was found during the identification pro‐

cess.
Matched Template The template that is found for the invoice that was tested. If this value is

empty, it means that the identification settings of the template did not yield any results
for the invoice used. In that case the settings for the current template are not applied
to this invoice.

Found checksum values All “validatable” values that were found on the invoice and that can
be used for identification, such as bank account and VAT numbers.
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Under the heading Data Extraction Job results any fields that have been extracted can be seen
and with which value(s). This is subdivided into header and line fields.

On the Raw text tab the text data that was used for recognition can be seen. For each page
the source from which the data came is shown under Source. When existing text from a PDF
is used it says Pdf here and when text was read from the image using OCR it will say Ocr.

At the top of the screen with test results, you have the option of selecting a template manually
and performing a test on it. Thiswill skip the identification and show the results that the invoice
from the current template would yield if it were tested using the selected template. This can
be useful when a user has created a new template for a creditor for whom a template already
existed. You can then check whether the new template will yield the correct results. If that
is the case, you can then adjust the identification settings of the existing template so that the
new invoice is also matched with it. In that case you can delete the new template.

1.4 Put into use
Once you have completed the configuration of the template you can indicate this by setting its
status to Complete and choosing Save.

1.5 Regular expressions
In a number of places in ImageCapture you can use a regular expression (short name: regex),
for example as a filter. This can be used to control recognition, for example by stating that only
values of 8 digits may be used. Regular expressions offer so many possibilities, it is almost a
programming language in its own right. The documentation in this regard limits itself to a few
examples. The internet provides a wide range of sources that describe regular expressions in
more detail.

1.5.1 Example 1: Order numbers
If an order number has to be found that starts with the letters ORD followed by 5, 6 or 7 dig‐
its, then the following regex can be used: ^ORD\d{5,7}$. This regex includes the following
components:

• The caret (^ ) states that the start of a value must be matched. Therefore the value
WOORD12345 would not be used, because there are characters before ORD.

• The text ORD indicates this text must appear literally.
• The notation \d{5,7} indicates there must be a minimum of 5 and a maximum of 7

digits present. \d here stands for digits and the number of times this kind of character
must appear is specified between curly brackets ({}).

• The dollar sign ($) states that the end of a value must be matched. Therefore the value
ORD12345678 would not be used, because it contains one extra digit.

1.5.2 Example 2: License plates
To read out Dutch license plates, the composition of which has changed a few times in recent
years, the following regex can be used:
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\d{1}-[A-Z]{3}-\d{2}|\d{2}-[A-Z]{3}-\d{1}|\d{2}-[A-Z]{2}-[A-Z]{2}|
[A-Z]{2}-[A-Z]{2}-\d{2}|[A-Z]{2}-\d{3}-[A-Z]{1}

This regex actually contains five separate regexes, that are combined using the pipe symbol (|),
so that a value must match one of those regexes. This regex is based on the use of minus signs
(-) as hyphen and of capital letters. The following combinations can then be recognized:

• 0‐AAA‐00
• 00‐AAA‐0
• 00‐AA‐AA
• AA‐AA‐00
• AA‐000‐A

In this case each regex consists of combinations of a number of digits, such as \d{1} for one
digit, and a number of capital letters, such as [A-Z]{3} for three capital letters, with a hyphen
(-) between them.

1.5.3 Example 3: Item codes
The pipe symbol from the previous example also needs to be used if, for example, the following
values need to be recognized:

• ART‐123456‐001
• ART‐123456‐01
• ART‐123456‐1
• ART‐123456
• COD‐123456‐001
• COD‐123456‐01
• COD‐123456‐1
• COD‐123456

The corresponding regex then is ^(ART|COD)-\d{6}(-\d{1,3})?$. This regex includes the
following components:

• The ^(ART|COD) part makes sure that the value must start with either ART or COD.
• The -\d{6} part makes sure there is a hyphen plus 6 digits next.
• By enclosing part -\d{1,3} with parentheses followed by a question mark makes sure

that optionally a hyphen and 1, 2 or 3 digits may follow.
• The dollar sign makes sure that nothing else may follow the value.
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Chapter 2

Client

This chapter gives a general description of the workflow in ImageCapture for end users. Since
ImageCapture is a dynamic application in which a great many functions can be enabled or dis‐
abled, functionality not available in your configuration may possibly be explained here. For
significant deviations a separate document with specific instructions will be supplied. Further‐
more, in ImageCapture all buttons are providedwith so‐called tool tips, which are shownwhen
you hover the mouse arrow above them. These tool tips contain a description of the function‐
ality of the button and, if applicable, the hot key with which this function can be invoked using
the keyboard.

2.1 Navigation within ImageCapture
• Launch ImageCapture 8.18 Client using the shortcut in the StartMenu or on the Desktop.
• When you are not using Windows Authentication you will enter the login screen, where

you have to enter your ImageCapture user name and password. In some cases a third
field will appear, where a license group has to be chosen, see Figure 2.1.

• After logging in you enter the Classes screen, see Figure 2.2. In this screen you will find
all classes — document streams — available to you. If there are already documents
present in a class this is indicated by colored bars, like at the bottom of the Purchase
invoices with ImageCapture IIR block. A class can be opened by double‐clicking it or by
selecting the correct class and clicking theOpen class button in themenu bar. When you
wish to add new documents to a class, you should choose the right class for the type of
documents, possibly relying on the descriptions below the class names.

• When you have opened a class, you will see three columns, see Figure 2.3:
– Jobs: In this list you will find all jobs you can process. Some of these jobs need user

input, like importing, scanning or verifying. Other jobs do not need user input and
are grouped under the headings Unattended jobs. Each job containing documents
to be processed will indicate this by colored numbers, as seen in the Verifying job.
A job can be started by double‐clicking it or by selecting the correct job and clicking
Process in the menu bar.

– Filters: Here you can filter the documents by all sorts of properties, like branch,
administration or creditor.

13
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Figure 2.1: Logging in
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Figure 2.2: Classes
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– Documents: This column contains information about the number of documents
in the current class, which you may see and/or process, divided by status. These
numbers depend on the filter chosen in the middle column.

Figure 2.3: Jobs

By clicking the underlined counters in the Jobs and Documents columns you will open the
Documents screen. Here you can view images and other information from these documents.
When you open the Documents screen using the number after Total youwill see all documents
available to you. When you do this using the number after the text Pending in a specific job,
then youwill only see the documents ready for that specific job. You can findmore information
on the Documents screen in its paragraph below.

2.2 Synchronizing online data
ImageCapture contains a number of connections to online applications, where the data from
the online application is synchronized to the ImageCapture database. This local data is then
shown in several jobs. Most of these configurations contain background tasks that perform
the synchronization, keeping the local data up to date. Sometimes this synchronization lags
behind somewhat, for example when you have just created a creditor in the online application
and no background task has run since. During Verifying, for instance, you will then notice
that the particular creditor is missing in the list of creditors. In that case you can perform
the synchronization manually if your application manager allows it. To do this, perform the
following steps:
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• Stop the process using the Stop button.
• Open the Tools → (name of online application) credentialsmenu.
• Choose the account and, if applicable for the online application chosen, the administra‐

tion(s) for which you wish to synchronize data.
• Click the Retrieve button. You will now see a screen like in Figure 2.4.
• You now see the different types of data that can be synchronized and when these have

been synchronized last for the selected administration(s). Here choose one or more
types of data youwish to synchronize and clickOK. Keep inmind that this synchronization
may take a long time when you choose many administrations and/or types of data.

• Close the credentials screen.
• Start the process again where you left off. The particular list now contains the newly

synchronized data.

Figure 2.4: Synchronizing online data
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Documents screen

This screen contains a view of all documents visible to you, see Figure 3.1. In it, all data rele‐
vant to these documents can be viewed and a number of actions can be performed on these
documents. These are the actions using the buttons in the menu bar and changing the priority.
Other adjustments, like changing fields values or the images of the document are not possible
in this screen and can only be made within the normal process.

Figure 3.1: Documents screen

In the top section all documents are listed vertically. In this list a number of properties of the
document are shown, like creation date, user and status. The columns shown can be adjusted
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using the View → Select columns menu in the top right of the screen. The list can be filtered
by entering a value in the text field directly above the list. Only documents where this value
occurs in at least one column will then be shown.

In the list of documents it is also possible to change the priority of a document. This priority
determines the sequence in which the documents are processed and takes precedence over
the normal processing order, namely the order in which the documents were created. This
allows you, for instance, to set the priority to Low for an invoice for which the corresponding
goods have not yet been delivered. You will then be presented this invoice last, so that you will
not have to skip it using Skip or Skip again in order to process the other documents. Conversely,
you can set the priority to High to have an invoice processed with urgency. This is usually only
necessary in environments where large amounts of invoices are processed.

When one document is selected in the list, the preview and all field values of that document
are shown in the bottom section of the screen. The preview also offers the ability to directly
print the image(s) or save them as TIFF or PDF file.

The tool bar above the list of documents contains a number of functions. Depending on your
configuration they may not all be available:

3.0.1 Move back
In order to process a document it is sometimes necessary to move it back one or more steps
in the process, for example because an error occurred in processing, which has been solved in
the meantime. To do this select the particular document and then click theMove back button.
Select the step to which the document should be moved in the opened dialog.

Note: depending on the step to which the document is moved back, previously filled fields
may be expunged and should be coded again.

3.0.2 Deactivate and Activate
It can occur that a document has actually been imported into ImageCapture, but cannot yet
be entered into or processed in the workflow, for instance because it is an invoice that may
not yet be entered into the accounts. In that case it is possible to deactivate such a document.
By doing so, the document remains in the ImageCapture database, yet is not shown in the
process. As soon as the document may be processed again you can activate the document
with the Activate button in order to include it again in the process.

3.0.3 Delete
In some cases there may be a document in ImageCapture, which should not be processed
further. This can occur when for example it turns out an invoice has already been entered
previously. In that case you can remove the document from ImageCapture using the Delete
button.

Note: this action is irreversible!
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3.0.4 Process
When you wish to process one or more documents immediately, without having to process
any other documents first, you can select these documents and click the Process button. Now
you immediately start processing the selected documents. The documents should however
be pending in a job you are allowed to process. This can for instance be useful when you wish
to immediately process a supplier’s invoice that arrived later. You can then locate this one
document using ImageCapture’s filtering abilities and process it immediately.

3.1 Status
The current status of each document is displayed in the Status column. In it the following
values can occur:

Imported Files have been moved from an external source to the database, e.g. uploaded via
the Web Client or imported from an e‐mail. No pages have been created yet.

Preprocessed Pages have been created from source files and necessary actions have been
performed. Examples of these actions are automatic rotation or barcode recognition for
separation purposes.

Pending The document is queued for processing in the job shown in the Job column.
Waiting An automatic step could not yet be completed, for example because a file exchange

with an external application has not been completed. The Client Service will retry pro‐
cessing the document when at least 5 minutes have passed since the last attempt.

Skipped The document has been skipped by a user and will be presented in the process again
next time.

Moved back The document has been moved back to a previous step by a user and will be
presented there again in the process.

Unattended failed An automatic step could not be completed and should now be performed
manually.

Errored An error has occurred in an automatic step. According to the message shown in the
Message column it can be determined how this error should be solved.

Deactivated The document has been deactivated by a user and will only be presented again
in the process after it has been manually activated again.

Finished The document does not need further processing. A document can have this status
for one of two reasons. Either the document has prematurely stopped in the process,
e.g. because it has been split into new documents or has been merged with other exist‐
ing documents. Or it has been processed completely and may be deleted manually. If
necessary, the option to automatically delete these documents in both cases can be set
in the Manager.
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Importing (Import Job)

To be able to add new documents to a class you need to scan or import them. This usually is
the first job in the list under Jobs. When you start this job you will see the Figure 4.1 screen.
In the top of the screen you can choose the source you wish to use. Depending on the source,
more buttons will become available.

Figure 4.1: Scanning or importing
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4.1 Receiving documents
Documents can enter your organization in different ways. For each there are different ways to
put them into ImageCapture.

4.1.1 Paper documents
Documents received on paper will always have to be scanned. This can be done directly from
ImageCapture, but also with a multifunctional (MFP) or network scanner.

4.1.2 Digital documents
Documents can be received digitally in various ways:

• Via email. Depending on the configuration, these documents can be imported directly
from themailbox or should be saved in a specific location on the network or local system.

• From an online environment, like a customer or user portal. Direct import is possible
from supported environments. From other environments documents should be down‐
loaded manually and saved in a specific location on the network or local system.

4.2 Preparing documents
Depending on your configuration, incoming documents usually have to be grouped by adminis‐
tration, department and/or type (purchase / sales invoices). With paper documents thismeans
making separate piles, with digital documents this means saving each document in the correct
location.

With paper documents it is in some cases necessary to mark the document separation in ad‐
vance using barcode stickers or sheets.

4.3 Scanning
When you choose a scanner as source, a second list will appear, where you can choose the
scan profile. After choosing a scan profile, wait for the scanner to finish initializing and the
Scan button to appear. Then press Scan to scan the documents. Changing the scanner settings
can be done by pressing the Scan Settings button. This can be used when certain settings
should be used for a specific document. Enable the option Duplex to scan double‐sided, for
instance, or change bit depth to scan in color. Here you can also set the contrast value or select
a different paper format.

4.4 Importing
Press Import to import all available documents from this source’s predefined import location.
With some sources an Open button is also available. You can use this to import one or more
specific documents from the import location or a custom location.
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4.5 Processing documents
The documents are inserted into one or more batches during the scan or import process, de‐
pending on the configuration. A batch contains one or more documents. A document contains
one or more pages. All batches, pages and documents are visible in the left part of the screen.
In the middle of the screen all documents in the first batch are shown. A vertical dotted line
indicates the separation between documents. When this separation is not right it can be cor‐
rected utilizing the Split and Combine buttons to split or combine documents respectively. It is
also possible to drag and drop pages between documents and batches. Especially when scan‐
ning, check the quality and completeness of the pages. Depending on the configuration, there
may be additional functions available to adjust pages, for example rotating or changing the
size.

Note: check the document separation well, because this cannot be changed further on in the
process.

During scanning or importing, field values are also assigned to batches and documents. When
these are not filled completely or not correctly, the documents or batches are displayed in red
and these values should be filled in manually at the right side of the screen.

Note: Field values shown under Batch Fields apply to all documents in the current batch. This
means that when changing such a value, it is changed for all documents in that batch, also
when only a single document is selected. For instance, when you wish to assign one single
document to another administration, you can create a new batch with the New batch button
at the left bottom of the screen, drag the document to it and change the field values.

When the document separation is correct and all field values are filled correctly, all documents
can be sent to the next step in the process using the Save & Next button in the top menu bar.
After pressing this button the Client will also proceed to the next job. When you do not wish
to do so, because you want to import documents from another source, you can use the Save
batch or Save all button at the left bottom of the screen.

Note: If you end the process using the Stop button in the topmenu bar while there are still doc‐
uments in the list, automatic separation and manual actions performed on these documents
up to then are undone. Scanned documents are lost and have to be scanned again. Files,
e‐mails and such have been stored in the database during import and have therefore been re‐
moved from the source. They can be separated again next time using the Previously imported
button.
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Verifying (Index Job)

This step is basically meant to assign extra data to a document and can appear under different
names. When processing invoices, a job called Verifying is usually present, in which header
and line entry data can be added to the document. An Editing creditor data job can also be
present, for instance, to create or edit creditors. When processing mail, an Index documents
job can be present, in which the document type and routing within the organization can be
chosen. When starting this job you will see the Figure 5.1 screen.

Figure 5.1: Verifying

In this step, depending on the configuration, header and line fields can be filled. Because of
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dependencies between these fields it is advisable to fill them in from top to bottom and left to
right. In any case, all fields colored red should be corrected, just aswith importing. Also check if
all other fields are correct. Using the keyboard you can jump to the next or previous field using
Tab or Shift+Tab. All automatically extracted values aremarked yellowon the document. When
you select such a value the marking turns blue. When the extracted value is on a page other
than the current one, this page is automatically shown. This behavior can be disabled using the
Lock page button below the document. You can also extract a value manually using interactive
OCR. To do this, select the relevant field, hold down the Shift button and draw a frame around
the value to be read using the mouse. When you read an amount using interactive OCR at the
header level and you select multiple amounts, then the resulting amount is calculated.

When processing invoices, the very first header field is where the creditor or debtor should
be chosen. It is chosen automatically by ImageCapture by reading the bank account and VAT
number on the invoice using OCR text recognition and comparing these with the numbers
recorded in the underlying application. This automatic link will not work when the quality of
the invoice is insufficient or when the numbers found do not match those in the application.
In that case, the creditor or debtor can be chosen manually. The automatic identification can
potentially be adjusted using a template. A template can be requested when the recognition
of invoices of a specific creditor or debtor, or the automatic extraction of its field values, is
consistently wrong. You can do this by clicking the button with the three dots in the Template
field. Check to see if there already is a template for this creditor. If so, you can add a comment
by double‐clicking the yellow bar. If a template for this creditor does not exist yet, you can
create it by clicking New Template, see Figure 5.2. Then enter a clear description of the reason
why a template is needed. The invoice is then saved separately in the database, so that the
application manager can optimize its recognition at a later time.

When line fields are applicable in this step, they are shown at the bottom of the screen. These
line fields can for instance be used to particularize invoice lines. Depending on the configura‐
tion and underlying application several links can also be made, like linking to existing registra‐
tions of tours or orders, for example. Using the buttons left of these lines several actions can
be performed, like the addition and removal of lines. It is possible to generate lines automati‐
cally by extracting multiple vertically listed values using interactive OCR. This can for example
be convenient when dividing lines per article group or VAT code.

Depending on the configuration, extra functions may be available to adjust pages, for instance
by rotating them or by creating an annotation with a comment or image.

When all conditions are met, the Save & Next button in the menu bar will be clickable. By
clicking it or pressing Ctrl+Enter you can advance the document to the next step in the process.
You are then presented the next document. When there are no more documents pending in
the current step, the Client will proceed with the next job.

Apart from the button Save & Next, the menu bar contains a number of useful functions. De‐
pending on your configuration, they might not all be available:

Stop Stops the current process and returns to the list of jobs. Changes in the current document
are not saved.

Skip Skips the current document after entering a reason. The next time this job is processed,
this document will be presented again.

Skip Again Skips again a document that was skipped before, without having to enter a reason
again.
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Figure 5.2: Requesting a template
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Move back Moves a document to a previous step in the process to be processed again. All
current changes are undone.

Deactivate Deactivates the document, so that is will only be presented again after manually
activating it via the Documents screen.

Delete Removes the current document from ImageCapture. This action is irreversible!
Restart Undoes all changes to the current document.
Undo queue Offers the possibility to see recently processed documents to, for instance, pre‐

vent double entries or to retrieve them and correct mistakes.
User actions Configurable actions for specific links to underlying applications.
View → Layout Changes the layout of the screen, including the possibility to split it over mul‐

tiple screens.
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Linking data (Extended Index Job)

This step is basically meant to link documents to existing data in an underlying application
and can appear under different names. When processing freight documents, there usually is
a Linking tour data job, where the document can be linked to one or more shipments or tours.
When starting this job you will see the Figure 6.1 screen.

Figure 6.1: Linking data

Broadly speaking this job does the same as the Verifying (Index Job) job. The most important
difference is that the lines at the bottom of the screen represent data from the underlying
application and that these cannot be edited. In this job, the document must be linked to one
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or more lines by selecting these lines and clicking Save & Next or to only one line by double‐
clicking it. In the Manager it can be configured so that lines previously linked to a document
are indicated by a green color.

Apart from linking the correct line(s), depending on your configuration, it is possible to change
field values under the heading Fields. In some cases fields will be available that are exclusively
used for retrieving the correct lines, like a date range within which the lines should fall. In that
case you can click the Refresh button at the bottom of the screen after changing these fields
to retrieve the new set of lines. When you wish to search for a particular value in the existing
set of lines, you can click the Filter button. You will see a pop‐up in which you can enter the
value or select a previously filled in value.
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Application Manager
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Chapter 7

Requirements

Subjects in this chapter:
• ImageCapture infrastructure and system requirements.
• Preconditions for links to external applications.

7.1 Infrastructure

7.1.1 Client‐Server
ImageCapture consists of several components that comply to the client‐server model. The
Client is fullymulti‐user and can be used concurrently by multiple users frommultipleworksta‐
tions, while the database and License Service are installed on a server that should be accessible
from any workstation. These components need not necessarily all be on the same server, they
may also be distributed across multiple servers. Optionally, one or more systems can be con‐
figured with the Client Service. Incidentally, in a single‐user environment all client and server
software may be installed on a single workstation.

7.1.2 Network
When ImageCapture is used on multiple workstations or servers, a shared network folder is
required. This will contain the global configuration file, which is used by each workstation and
includes the location of the database and the License Service. Additionally, the layout and
sheet files of the Barcode Writer are accessible for all workstations through this folder.

7.1.3 Scanner
Scan Sys recommends the use of a local Fujitsu scanner. These come with PaperStream
software that also installs the ISIS and Twain drivers. If the ISIS settings are adjusted from
ImageCapture via PaperStream, they are all stored in the ImageCapture database and also
used on every system. For Twain however, only the settings described in the Twain speci‐
fication are saved, see https://www.twain.org/specification. As a result, only PaperStream
settings such as brightness and contrast are saved for Twain. For ISIS, more advanced
PaperStream settings are also stored, such as deviating paper sizes and noise reduction.

Scanning with WIA (Windows Image Acquisition) is not supported by ImageCapture.
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Furthermore, any network scanner or MFP (Multi Function Product/Printer/Peripheral) with
a scan to file to TIFF with 300 dpi can also be used to scan documents and import them into
ImageCapture.

7.2 Systems

7.2.1 ImageCapture
The installer always installs the combination of both the Client and the Manager so that our
support department can access your configuration if necessary. See Table 7.1 for theminimum
system requirements. Prior to the implementation process, the customermust ensure that all
system requirements are met.

Table 7.1: Minimum system requirements ImageCapture

System Requirements

PC Connected to protective earth
Keyboard and mouse

Processor Intel® Core™ 2 Duo 2.4 GHz or higher
Memory 4 GB RAM on workstations

500 MB extra RAM per session on servers
Monitor Video card and monitor

Resolution of 1280 x 1024
Network connection 100 Mb/s
Hard disk space 1 GB disk space for installation

10 GB disk space for temporary files per workstation
10 GB disk space for the database

Operating system Microsoft Windows 7, 8, 8.1 or 10
Microsoft Windows Server 2008 R2, 2012, 2012 R2, 2016 or 2019

Software Microsoft .NET Framework 4.7.2
Microsoft SQL Server 2012, 2014, 2016, 2017 or 2019

Configuration For correct operation of the OCR engine, a valid
DNS‐entry must exist for localhost. This is the case
when the command ping localhost gives a result.

7.2.2 Client Service
The Client Service needs 1 GB memory space and 10 GB temporary disk space per requested
core/license.

7.2.3 Web Client
The Web Client is a web application that runs under Internet Information Services (IIS) on a
server. This web application can be used simultaneously by multiple users via a web browser.
See Table 7.2 for the additional requirements of the Web Client. All other devices, including
smart phones, are not supported.
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Table 7.2: Additional system requirements Web Client

System Requirements

Windows PC/laptop Chrome (latest version)
Firefox (latest version)
Edge (latest version)
Internet Explorer (latest version)

iMac/Macbook Chrome (latest version)
Firefox (latest version)

iPad Safari (latest iOS)
Android tablet Chrome (latest version)
Screen resolution minimal 768 pixels wide
Browser settings Cookies enabled

Local storage enabled
JavaScript enabled

Server Microsoft IIS 7.0 SP1 or higher

TheWeb Client can only be used over an encrypted connection (https). For use in a production
environment a Trusted Certificate is therefore required. In for instance a test environment a
Self‐Signed Certificate can also be created during the installation.

For correct operation of the Web Client, the installation of a number of IIS components is
required. These components can be installed on theWindows Features screen under Internet
Information Services.

• Web Management Tools:
– IIS Management Console

• World Wide Web Services → Application Development Features:
– .NET Extensibility *
– ASP.NET *
– ISAPI Extensions
– ISAPI Filters

• World Wide Web Services → Common HTTP Features:
– Default Document
– Static Content

• World Wide Web Services → Security:
– Request Filtering
– Windows Authentication **

*: Recent versions of IIS contain multiple versions of these components. In that case, version
4.x is required.

**: This component is only required when using Windows authentication to log in to the Web
Client.

7.2.4 License Service
In order to use ImageCapture, the License Service with an activated license is required. The
License Service manages the logged‐on users and is responsible for keeping track of active
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sessions and releasing class locks and document locks in the database.

Preferably, the License Service is only installed once on a central server. The system require‐
ments in terms of the operating system and the software required for the License Service are
similar to those of ImageCapture, see Table 7.1.

7.2.5 Barcode Writer
When working with the so‐called barcode sticker sheets, the Barcode Writer must be installed
on a workstation on which they can be directly printed.

7.2.6 SQL Server
See Table 7.1 for the supported versions of SQL Server. The following requirements apply to
the configuration:

• The option Allow Triggers to Fire Others must be enabled on the SQL Server instance
used.

• Workstations must be able to connect to SQL Server:
– The SQL server must allow remote connections.
– The TCP/IP protocol must be activated.
– The firewall must allow connections to SQL Server.

ImageCapture can be used in conjunction with the free Microsoft SQL Server Express editions.
However, note that those have the following limitations:

• The maximum database size is 4 GB (2008) or 10 GB (2008 R2 and up).
• Only 1 processor and at most 4 cores are used.
• At most 1 GB RAM is used.

7.3 Permissions and management

7.3.1 SQL Server
The ImageCapture database must be created with SQL Server sa‐permissions. For daily use,
dbo‐permissions are required. The database should run synchronously with your customer
backup procedure.

7.3.2 ImageCapture
The ImageCapture installer must be executed with Windows Administrator permissions. Dur‐
ing installation, all the required third‐party software will also be installed on your system.
Shortcuts for starting the Client and Manager will be created in the Windows Start Menu as
well. See Table 7.3 for the precise locations.

In order to be able to fully uninstall ImageCapture at a later date from the list of installed
programs, a number of registry keys will be created during the installation. See Table 7.4 for a
precise overview of what will be created in the Windows registry.
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The system permissions necessary for daily use are described in Table 7.5, whereby
ImageCapture runs on 64‐bit systems as a 32‐bit process in Windows‐on‐Windows.
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Table 7.3: Installed software ImageCapture

Software Location

ImageCapture <installation folder>1

<start menu>2

Leadtools OCR Runtime <installation folder>\OcrRuntime
Export libraries3 <installation folder>\Libraries
Microsoft C++ Runtime %WINDIR%
Pixtran ISIS4 %WINDIR%\Pixtran

Table 7.4: Created keys in Windows Registry

Key Name Value

<software>5 Install_Dir <installation folder>
<uninstall>6 DisplayName Scan Sys ImageCapture 8.18
<uninstall> NoModify 1
<uninstall> NoRepair 1
<uninstall> UninstallString <installation folder>\uninstall.exe

Table 7.5: Permissions for the daily use of ImageCapture

Description Location Permissions

ImageCapture <installation folder> read/execute
system settings ImageCapture.ini7 read/write
global settings Global.ini read

set in ImageCapture.ini
user preferences Client.ini and Manager.ini read/write
“temp” folder local folder read/write

set in ImageCapture.ini
log folder local folder read/write

set in ImageCapture.ini
database SQL Server dbo on database

set in Global.ini
Leadtools temp parent folders of %TMP% list

%TMP% read/write
Accusoft SSM %TMP%\Accusoft read/write
Pixtran ISIS %WINDIR%\Pixtran read
System files %WINDIR% and %WINDIR%\System32 read

1The default installation folder is: %PROGRAMFILES%\Scan Sys\ImageCapture 8.18, but this can be
changed if required during the installation.

2Location of Windows Start Menu: %PROGRAMDATA%\Microsoft\Windows\Start Menu\Programs
3During installation, all dynamic link libraries are registered with regsvr32.exe.
4The Pixtran ISIS files are only used for scanning, but they are required for starting the Client and Manager.
5HKLM\Software \Scan Sys\ImageCapture 8.18
6HKLM\Software \Microsoft \Windows \CurrentVersion \Uninstall \ImageCapture 8.18

CHAPTER 7. REQUIREMENTS 36



ImageCapture 8.18 Documentation

Description Location Permissions

Microsoft .NET Framework
Microsoft C++ Runtime
external applications see Section 7.4 read/write

7.3.3 License Service
The License Service installer must be executed withWindows Administrator permissions. Dur‐
ing the installation, only files will be copied to the installation folder. The default installa‐
tion folder is %PROGRAMFILES%\Scan Sys\ImageCapture License Service, but this can
be changed if required.

After running the installer, the License Service must be registered as a Windows Service using
a separate batch script. Optionally, the executing user of this service can be changed.

Finally, the system permissions necessary for daily use are described in Table 7.6.

Table 7.6: Permissions for the daily use of License Service

Description Location Permissions

License Service <installation folder> read
system settings LicenseService.ini8 read
log folder local folder read/write

set in LicenseService.ini
license folder local folder read/write

set in LicenseService.ini

7.3.4 Kofax
During the installation of Kofax on Windows 7 or higher UAC must be turned off.

7.3.5 Common problems
• Several users have reported that anti‐virus software can prevent ImageCapture from

starting, or can cause it to shut down unexpectedly. In the event of such a problem,
check first to see whether your anti‐virus software is the cause.

• On systems where the user permissions are strictly controlled, it is possible that the
imaging component of ImageCapture will cause problems. This is because a component
of Accusoft is trying to save temporary (.ssm) files to the Windows temp folder (%TMP%)
in a subfolder called Accusoft. If this is not possible, this can cause multiple errors in
ImageCapture, including the unhelpful message “Illegal characters in path”. This can be

7The location of the ImageCapture system settings is always: %PROGRAMDATA%\Scan Sys\ImageCapture\
ImageCapture.ini 8.18, this cannot be changed.

8The location of the License Service settings is always: %PROGRAMDATA%\Scan Sys\License Service\
LicenseService.ini, this cannot be changed.
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solved by expanding the permissions of the current user within Windows, but alterna‐
tively, there is a workaround available. Place a text file called pegasusworkerloader.
ini in the folder <installation folder>\ImageCapture or, when this occurs in the
Client Service, <installation folder>\ClientService. Make sure the file has the
following contents, whereby the completed path points to a folder where the user who
is starting ImageCapture has write permissions:

[pegasusworkerloader]
tempdir = C:\Users\Public\AppData\Local\Temp

7.4 Interfaces to external applications
A number of specific interfaces to external applications require extra attention, such as special
system permissions or additional software. This additional software is only required on the
system upon which the interface will actually be used. For example, on systems where no
exports will be carried out, the installation of additional software is not required.
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New Installation

Subjects in this chapter:
• Installing and configuring the License Service and ImageCapture.
• Creation of the database from the Manager.
• Adding and activating your license.
• Silent installation and virtualisation.

8.1 SQL Server
Prior to the installation of ImageCapture, a SQL Server must first be installed, see the system
requirements in Section 7.2 for details on supported versions. If there is no SQL Server installed,
a SQL Server Express edition can be used free of charge. Scan Sys is not aware of your IT
infrastructure, so we will not install an SQL Server.

8.2 License Service
Before the installation of the License Service, determine whether your situation is a single or
multi‐user environment and decide where the License Service will run from:

• Start the installer <installation cd>\Tools\ImageCapture License Service
5.4.2.exe, or a higher version.

• Accept the default installation folder and continue the rest of the wizard.
• Run the script <installation folder>\_install.bat to register the License Service

inWindows. If the registration completes successfully, the commandwindowwill display
the message “The transacted install has completed”.

The settings of the License Service are stored in the file LicenseService.ini1, which will be
automatically createdwith the default settings the first time the License Service is started. This
configuration file can also be createdmanually beforehand or subsequently changed using the
License Service Config Tool from the installation folder:

• Start the LicenseServiceConfigTool in the installation folder.
1The location of the License Service settings is always: %PROGRAMDATA%\Scan Sys\ImageCapture\

LicenseService.ini, this cannot be changed.
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• Click on the two plus buttons to create the log2 and license folder3.
• Use the suggested port, unless it is already in use.
• Confirm the changes with OK to save the LicenseService.ini.

Finally, start the License Service:

• The License Service can be started from the Services screen in Administrative Tools on
the Control Panel, or with the included _start.bat script in the installation folder.

• Initialisation errors are written to the Application Log in Windows, which is available via
the Event Viewer. Upon completion of the initialisation, it will be logged in the defined
log folder.

8.3 ImageCapture
Before installing ImageCapture, decide the following:

• Will ImageCapture be used from multiple workstations?
• On which SQL Server will the database be installed?
• Where will the ini file for global settings be?

8.3.1 Installation on a workstation
• Start the installer <installation cd>\ImageCapture 8.18.x.exe.
• By default, Manager and Client will already be checked. Do not yet choose for Client

Service orWeb Client, their installation and configuration will be discussed later.
• Choose ImageCapture.ini if you already have a system settings file configured and want

this to be copied onto the local workstation by the installer.
• Choose Installer backup if you wish to retain the installer on your local workstation as a

backup after installation.
• Only change the default installation folder if absolutely necessary. Always use the ver‐

sion number in the last sub folder, because of future updates to new major versions.
• Continue the rest of the wizard.

8.3.2 System settings
The ImageCapture system settings are stored in the file ImageCapture.ini4, which is auto‐
matically created when starting the Manager:

• Now start the Manager for the first time via the Start menu → All Programs → Scan Sys
→ ImageCapture 8.18 Manager.

• Open the menu Tools → Options.
• Choose the tabMachine for the system settings.
• Set Global config path to the desired location of the global settings, including the file

name and the extension .ini. Now press the plus sign to create the ini file.
2Default log folder: %PROGRAMDATA%\Scan Sys\ImageCapture\Log
3Default license folder: %PROGRAMDATA%\Scan Sys\ImageCapture\Licenses
4The location of the ImageCapture system settings is always: %PROGRAMDATA%\Scan Sys\ImageCapture\

ImageCapture.ini 8.18, this cannot be changed.
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Global config path Location of the ini file for the global settings. For example, use
ImageCaptureGlobal.ini as the file name.

In a single‐user environment this file is stored on the local workstation. In this case,
use the same folder as for the system settings, i.e. %PROGRAMDATA%\Scan Sys\
ImageCapture.

In a multi‐user environment, this file is shared with all other workstations and must be
stored on a shared network folder.

8.3.3 Environment settings
The ImageCapture environment settings are also stored in the file ImageCapture.ini5:

• Choose the tab Environment.
• Fill in the settings in this tab and confirm with OK.

Temp folder The temporary folder must always be stored locally. This folder should never
refer to the network because this will have a very negative effect on the speed of
ImageCapture.

Log folder The log folder must also be stored locally, due to speed and the ability to log net‐
work faults.

Enable verbose logging Only enable this option at the request of Scan Sys.
Client priority Only use this option at the request of your system manager.

8.3.4 Global settings
The ImageCapture global settings are also stored in an ini file. Its location is described in the
previous step.

The first global setting is which SQL Server and ImageCapture database should be used. In this
chapter we will therefore start by creating a new, empty ImageCapture database:

• Open the menu File → Create Database…
• Set the Admin credentials to a user with sa‐permissions. These credentials will only be

used once for creating the database.
• SetDaily use credentials to a user that ImageCapturewill be using to access the database.
This user will become dbo of the database. We recommend using user name scansys
and a strong, unique password. In the event that this user does not yet exist, the user
will be automatically created by ImageCapture. The use of Windows authentication is
only possible if all Windows users who are going to start up ImageCapture receive the
correct permissions on the associated server and database. This includes the Windows
user under which any Client Service may be running and, in the case of the Web Client,
the Windows user under which IIS is running.

• Note that we recommend to not change the proposed database name, because its name
includes the version number of the database. This is especially useful during updates if
there are multiple ImageCapture databases stored on the server.

5The location of the ImageCapture system settings is always: %PROGRAMDATA%\Scan Sys\ImageCapture\
ImageCapture.ini, this cannot be changed.
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• Note that, starting from ImageCapture 4.3, all images are stored in the database instead
of in a separate global data folder. Such a folder will therefore no longer need to be
specified.

• Confirm with OK to create the database and to remember it as a global setting.
• Log in using an administrator user. The default administrator user has user name Admin

and password Admin.

Next configure the location of the newly installed License Service:

• Open the menu Tools → Options.
• Choose the tab Global.
• Under License Service fill in the host and port.
• Confirm the modified settings with OK.

Finally, add your license and activate it via Scan Sys:

• Open the menu File → Add New License.
• Choose your license file, which has probably been sent to you by e‐mail.
• For name, only change the default name license if your License Service will host mul‐

tiple licenses.
• Confirm with OK.
• Open the menu File → Activate Current License.
• Call Scan Sys during business hours on 0031 (0)15 ‐ 310 20 40 and ask for an activation

code for your license.

8.3.5 Database settings
Some settings are stored in the database:

• Open the menu Tools → Options.
• Choose the tab Database.

These include the possibility to customize the Web Client with a custom company logo, name
andURL. This is particularly useful in caseswhere theWeb Client is opened up to external users
that have no direct relationship with Scan Sys. It is also possible to configure the Sessions &
Locks screen and the various Credential screens to be shown to Administrators only. This is
useful in shared environments where users are not allowed to view user names and external
accounts of other users.

8.3.6 User preferences
For each user, the locations and sizes of theManager and Client screens are stored separately in
the folder %APPDATA%\Scan Sys\ImageCapture. In the Client, you can change the language
of your ImageCapture configuration:

• Open the menu Tools → Options in the Client.
• Choose the tab User.
• Choose the desired language and confirm with OK.
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8.4 Client Service
The Client Service can be installed on a server or on a workstation. It is recommended to be
installed on a server because it is always running. See Chapter 10 for technical information
about the Client Service.

Install the Client Service on a server:

• Start the installer <installation cd>\ImageCapture 8.18.x.exe.
• Choose Client Service.
• Only change the default installation folder if absolutely necessary. Always use the ver‐

sion number in the last sub folder, because of future updates to new major versions.
• Continue the rest of the wizard.

Configure the Client Service in the Manager:

• Start the ImageCapture Manager.
• For every Import and Index Job, set the visibility of all fields to On error or If Processing

attended, otherwise this Job cannot be processed unattended.
• An Import Job will only be processed unattended if it contains Importers that allow unat‐

tended processing. For example, for a File Importer, choose the tab Processing:
– Check Allow unattended import in Client Service.
– Check Allow unattended preprocessing in Client Service.
– Determine whether or not the Client Service is allowed to perform document sep‐

aration by (un)checking Separate unattended.
– Determine what should happen if a document contains validation errors in the Im‐

port Job. Select Process attended to process these documentsmanually orMark as
errored to give them the status Errored. The latter option disallows further process‐
ing in ImageCapture, but allows the imported files to be saved to disk to process
them in a different manner.

• Change all network paths with drive letters to UNC paths at Tools → Options and all
Importers and Exports.

• Go to Tools → Options:
– Choose on the tabMachine the desired number of cores.
– Set on the tab Environment the User name to a user that supports ImageCapture

authentication and is a member of a User Group that is linked to a license group
that allows the use of the Client Service.

Configure the Client Service in Windows:

• Execute the script <installation folder>\ClientService\_install.bat with
administrator permissions to register the Client Service in Windows. If the registration
completes successfully, the command window will display the message “The transacted
install has completed”.

• Go to Control Panel → Administrative Tools → Services:
– Set ImageCapture Client Service to start up automatically.
– Set Log On As to an account with sufficient permissions.
– Start the ImageCapture Client Service.
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8.5 Web Client
First install and configure the ImageCapture Manager and Client on the same server that the
Web Client will be running on. Ensure the Client can open a class without error messages
before continuing with the installation and configuration of the Web Client and Internet Infor‐
mation Services (IIS).

8.5.1 Installation on a server
Install the Web Client on the server where IIS is running:

• Start de installer <installation cd>\ImageCapture 8.18.x.exe.
• ChooseWeb Client.
• Only change the default installation folder if absolutely necessary. Always use the ver‐

sion number in the last sub folder, because of future updates to new major versions.
• Continue the rest of the wizard.

8.5.2 Configuration of IIS
Give the group Authenticated Users read and write permissions on the folder <log folder>
(default %PROGRAMDATA%\Scan Sys\ImageCapture\Log).

Go to Control Panel → System and Security → Administrative Tools and start Internet Informa‐
tion Services (IIS) Manager:

• Under Connections at the left, select the text Application Pools and under Actions at
the right, choose Add Application Pool…. Enter a name, e.g. ImageCapture, and then
choose .NET Framework v4.0.xxxxx. Confirm with OK.

• Select the newly created application pool in the list and under Actions, choose Advanced
Settings….

– Set the Enable 32‐Bit Applications option to True.
– Under Process Model select the line Identity and click the three dots behind Appli‐

cationPoolIdentity.
– Enter the user name and password of a Windows user with sufficient permissions,

see Table 7.5. Confirm with OK.
– Under Recycling set the option Regular Time Interval (minutes) to 0.
– Confirm with OK.

• Under Connections at the left, under Sites, choose the Default Web Site. In the context
menu (right mouse click), choose Add Application….

– Enter an Alias, e.g. ImageCapture.
– Click on the Select… button and select the newly created application pool. Confirm
with OK.

– For Physical path, use <installation folder>\WebClient. Note that Test Set‐
tings… does not work yet. Confirm with OK.

• If the Web Client must use Windows authentication:
– Expand the newly created application to display its subfolders.
– Right click onWinAuth.
– In the context menu, click Convert to Application and confirm with OK.
– Select the newly created applicationWinAuth if it is not selected yet.
– Under IIS, double‐click Authentication.
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– Set Windows Authentication to Enabled and all other methods to Disabled in the
list of authentication methods.

• Only create a new Self‐Signed Certificate if you do not own a Trusted Certificate yet. Us‐
ing a Self‐Signed Certificate is a security risk and is not suitable for production environ‐
ments:

– Under Connections at the left, select the server name and double click on Server
Certificates in the middle column.

– Under Actions, choose Create Self‐Signed Certificate and give it a name.
• Add an HTTPS binding:

– Select the Default Web Site and, under Actions, choose Bindings….
– Click on the Add… button and select https for Type.
– Select your own Trusted Certificate or the newly created certificate for SSL certifi‐

cate and confirm with OK.
• Under Sites, select the ImageCapture application and under Actions, choose Browse
*:443 (https). The log‐in screen of the Web Client will now be displayed. When using
a Self‐Signed Certificate, a warning will be shown indicating that the connection is not
secure which has to be ignored in that case.

8.5.3 Configuration of ImageCapture
Windows authentication

Enable Windows authentication in the Web Client by executing the following steps:

• Open the menu Tools → Options in the Manager.
• Choose the tab Global.
• UnderWeb Client check Allow Windows authentication.
• Confirm the modified settings with OK.

Database permissions

If Windows authentication is used to connect to the ImageCapture database and/or external
databases, the Windows user under which IIS runs must have permissions to access those
databases. This does not apply to SQL Server authentication, because in that case the user
name and password for the database have been defined in the Manager.

Changes to the configuration

Recycle the application pool after making changes to the system or global settings from the
Manager in order to use the new settings in theWebClient. To do this, use the <installation
folder>\WebClient\_reycleAppPool.bat script, or execute the following steps:

• Go to Control Panel → System and Security → Administrative Tools and start Internet
Information Services (IIS) Manager.

• Under Connections at the left, select the text Application Pools and select the applica‐
tion pool for ImageCapture in the middle column. Under Actions on the right, choose
Recycle….

Changes to classes, tables, etc. will be automatically loaded in theWeb Clientwithout recycling
the application pool.
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8.5.4 Security aspects
When using the Web Client, some security aspects must be kept in mind. It is important to
take these seriously and determine which of these aspects are relevant to your situation.

ClientAdmin and PowerAdmin logins

ImageCapture has two built‐in login accounts that partners and employees of Scan Sys can
use to log in, even if the maximum number of simultaneous users has been reached or if the
normal Admin password is unknown. These login accounts are disabled by default for theWeb
Client. They can be enabled in the Manager via Tools → Options → Global → Web Client →
Allow ClientAdmin and PowerAdmin logins. If theWeb Client can be reached from outside your
local network, it may be wise to leave these logins disabled.

Visibility of template images

Via Users and User Groups, users of the Web Client can be configured to not see each oth‐
ers documents. In this case, it is also important to make the images of templates invisible,
otherwise the invoice upon which a template is created will be visible to all users. You can
configure this behaviour in the Manager at the relevant Index Job by unchecking General →
Identification Settings → Display template images for non‐template users.

Password Field

When the value of a Password Field is set in a jobwhich is executed in theWeb Client, end users
can view the unencrypted password through the built‐in Developer Tools of the web browser.
This is not a problem if the user has to set the value manually. However, if the field is filled
from an external source, it is recommended to do that in an earlier unattended job, to prevent
end users from viewing the password.

IIS headers

IIS sends a number of headers back to the browser with every web page. If desired, you can
set up IIS so that certain headers will or will not be sent. Check the documentation for your
version of IIS for how to do this exactly.

Server header It is a good idea to disable this header, because it contains information about
the version of IIS that may help hackers to gain access to the server.

X‐Frame‐Options header It is recommended that this header be enabled to prevent so‐called
clickjacking attacks, because it forbids the browser to show theweb pagewithin another
web page.

8.5.5 Common problems
No access to eventlog

When theWeb Client does not have access to the eventlog, this can be fixed by giving the user
IIS_IUSRS full permissions on the eventlog registry key:

• Start theWindows Registry Editor, e.g. via Start → Run → regedit.
• Go to the key HKLM\SYSTEM\CurrentControlSet\services\eventlog.
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• In the ‘eventlog’ context menu, choose Permissions….
• Add the IIS_IUSRS user and give the user Full Control.

HTTP Error 404 ‐ Not Found

The error message indicates that the page you requested cannot be found. In the case of the
Web Client this can be the result of too few access permissions.

• Go to Control Panel → System and Security → Administrative Tools and start Internet
Information Services (IIS) Manager.

– Under Connections at the left, under Sites, select the ImageCapture application
and under Actions choose Basic Settings…. Select Connect as… and enter the cre‐
dentials of the Administrator under Specific User.

– Recycle the application pool.
• Reload the web page and check that it is working correctly.
• Return to the Internet Information Services (IIS) Manager.

– Reset the Path credentials to pass‐through authentication.
– Recycle the application pool once more.

• The web page should now work properly.

HTTP Error 500.19 – Internal Server Error

This error occurs if not all required IIS components have been installed, see Section 7.2.3.

After installation of a required component, it may be necessary to recreate the application
pool, see Section 8.5.2.

HTTP Error 500.21 ‐ Internal Server Error

This error occurs if ASP.NET has not been registered yet:

• Stop IIS.
• Start cmd.exe as administrator.
• Execute: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.
exe -i

• Start IIS.

8.6 Silent installation
A silent installation runs without any user interaction and without a user interface. This means
the userwill see so no screens andwill not be asked anything. This is useful for applicationman‐
agers who want to install ImageCapture on several systems, maybe even from an automated
script.

First make sure that you are fully familiar with the normal installation and configuration proce‐
dure before you start with silent installations. A silent installation always installs the Manager
and Client. If a ‘ImageCapture.ini’ file exists alongside the installer, it is automatically copied
to the correct location.

A silent installation is started via the command line and supports the following parameters.
Please note that these command line parameters are case sensitive:
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/S Start a silent installation without screen. The installer installs everything without further
user interaction being required.

/CLIENTSERVICE Install the Client Service as well.
/D Use a different default installation folder. Thismust be the last parameter on the command

line and it may not contain quotes, even if the folder contains spaces. Only absolute
paths can be used. This parameter can also be used in a normal installation with a user
interface.

Example of a silent installation in the default installation folder:

ImageCapture 8.18.x.exe /S

Example of a silent installation in a different folder:

ImageCapture 8.18.x.exe /S /D=F:\Applications\ImageCapture 8.18

The following batch script provides an example of performing a silent installation:

@ECHO OFF
ECHO Installing ImageCapture...

START "" /WAIT "ImageCapture 8.18.x.exe" /S
IF %ERRORLEVEL% NEQ 0 GOTO ERROR

ECHO Completed.
GOTO DONE
:ERROR
ECHO Failed with error code %ERRORLEVEL%.
EXIT /B %ERRORLEVEL%
:DONE

8.7 Virtualisation
In various customer situations, ImageCapture is virtualised with Citrix, Terminal Server or App‐
V. However, it is not possible to control a local scanner in these situations.

Scan Sys has no specialist knowledge of these virtual environments and provides no support
for these kinds of environments and any resulting problems.

8.8 Miscellaneous
There is a separate installer for the Barcode Writer with its own version number and release
schedule.
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Chapter 9

Updating Current Installation

Subjects in this chapter:
• Updating ImageCapture.
• Updating the database from the Manager.

9.1 ImageCapture
From ImageCapture 4.0 onwards it is possible to update the existing configuration to the most
recent version of ImageCapture. There are two types of update:

• Amajor update (from ImageCapture 4.4 to ImageCapture 4.6 or to ImageCapture 5.1)
• Aminor update (from ImageCapture 4.4.5 to ImageCapture 4.4.17)

With an update to a newmajor release, a new installation folder will be created in the Program
Files directory so that, if necessary, it will be easy to switch back to the version already installed.
The ImageCapture databasemust also be updatedwith a newmajor release. To be able towork
in the updated database, the ImageCapture software must be updated on all workstations.

With a minor update, the old installation folder is usually overwritten. In that case, it will
only be possible to switch back to the former version by reinstalling that version over the new
version.

9.1.1 Beforehand
Before performing an update, it is important to consider these issues:

• First check whether the current workstation still meets the system requirements that
correspond with this version of ImageCapture. For example, perhaps you use a version
of Windows or of Microsoft SQL Server that is no longer supported by the new version
of ImageCapture.

• With this update, check whether there are any update issues that are relevant to you. If
in doubt, contact Scan Sys for advice before proceeding with the update.
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9.1.2 Updating software
To update the software, the following steps must be executed with Windows Administrator
rights:

• If the Client Service is installed on this system:
– Open the Services1 screen in Windows.
– Stop the ImageCapture Client Service, if it is running.
– Also stop the ImageCapture Client Service Scheduler if it has been installed and is

running.
• If the Client Service is installed on this system and you are performing a major update:

– Open the Windows Services screen in Windows.
– Right click on the ImageCapture Client Service, choose Properties and select the

tab Log On (see Figure 9.2).
– Note the user under which this service is running. You will need this information

later.
– Delete the old Client Service from the Services screen by running the script
<installation folder>\ClientService\_uninstall.bat in the installation
folder of the old version of ImageCapture.

• If the Web Client is installed on this system:
– Start the Internet Information Services (IIS) Manager2.
– On the left, under Connections, select the ImageCapture application under Sites

and under Actions choose Basic Settings…. Note which Application pool is used by
ImageCapture. You will need this information later.

• If the Web Client is installed on this system and you are performing a minor update:
– Start the Internet Information Services (IIS) Manager.
– On the left, under Connections, select the text Application Pools, then select the
Application pool for ImageCapture in the middle. On the right, under Actions, se‐
lect Stop.

• Run the file <installation cd>\ImageCapture 8.18.x.exe to start the installation
wizard.

• Click on I Agree to agree with the license agreement.
• The installation wizard will now display the list with components to be installed (see

Figure 9.1). Check Client Service and/or the Web Client if you use these on this system
and click on Next.

• You now have to choose the folder in which ImageCapture will be installed:
– If you are performing amajor update, it is recommended to use the standard folder.
– If you are performing a minor update, adjust the Destination Folder to the folder

in which ImageCapture was previously installed. This is only necessary, when the
default folder was changed during the original installation.

• Click on Install to start the installation.
• After completion of the installation, click on Close to close the installation wizard.
• If the Client Service is installed on this system:

– If you are performing a major update, run the script <installation folder>
\ClientService\_install.bat in the installation folder of the new version to
add the new Client Service to the Services screen.

– Open the Windows Services screen in Windows.
1Control Panel → System and Security → Administrative Tools → Services
2Control Panel → System and Security → Administrative Tools → Internet Information Services (IIS) Manager
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– If you are performing a major update, configure the Client Service user via Proper‐
ties → Log On of the ImageCapture Client Service. Enter the same user as in the
previous version, as noted earlier.

– Start the ImageCapture Client Service.
• If the Web Client is installed on this system and you are performing a major update:

– Start the Internet Information Services (IIS) Manager.
– On the left, under Connections, select the ImageCapture application under Sites

and under Actions choose Basic Settings…. Here, change the Physical path to the
new location on the local disk.

– If you use Windows authentication in the Web Client:
* Expand the ImageCapture application to display its subfolders.
* Select the WinAuth folder and under Actions choose Basic Settings…. Here,

change the Physical path to the new location on the local disk.
– On the left, under Connections, select the text Application Pools, then select the
Application pool for ImageCapture in the middle. On the right, under Actions, se‐
lect Recycle or, if the Application pool is not yet active, select Start. As an alter‐
native to this step, you can run the script <installation folder>\WebClient\
_recycleAppPool.bat.

• If the Web Client is installed on this system and you are performing a minor update:
– Start the Internet Information Services (IIS) Manager.
– On the left, under Connections, select the text Application Pools, then select the
Application pool for ImageCapture in the middle. On the right, under Actions, se‐
lect Start.

Figure 9.1: Choosing components
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Figure 9.2: Configuring Client Service user

9.1.3 Updating database
After performing a major update of the software, the database will need to be updated. For
this update, it is advisable to ask all ImageCapture users within your organization to close the
application before the update commences. For updating the database, various update meth‐
ods are available. It is important to decide beforehand which method you are going to use,
because this update has an impact on all the users within your organization:

Create and update copy This is the standard method. With this method, a copy is created
of the existing database, after which the copy is updated. When using this method,
it is important that good agreements are made with all ImageCapture users regarding
the moment of the update and the procedure around it. The data in the ImageCapture
database is by default saved upon update, which means that, with this method the data
will be located in both the old and the new version following update. Because the old
database remains unchanged, users at other workstations with the old version of the
ImageCapture software, can continue to work with the old database. However, this
brings the risk that data is processed in duplicate, namely in both the old and the new
database. This can be prevented in a number of ways:

1. Ensure all data has been fully processed before starting the update.
2. During the update, delete all data from the newdatabase by enabling the checkbox

Delete all data from target database and continue to process old documents with
the old version of ImageCapture.

3. Arrangewith all users that theywill all workwith the new version from themoment
of the update.

The advantage of this method if that it is the easiest way to use the old and the new
versions alongside each other. This can be useful, for example if several users would

CHAPTER 9. UPDATING CURRENT INSTALLATION 52



ImageCapture 8.18 Documentation

like to test out the new version while other users wish to continue working with the old
version. With this method, if the new version works to your satisfaction, you will have
to delete the old database manually.

Create backup and update original Here a backup of the existing database is created on the
hard disk, after which the existing database is updated. The advantage of this method
is that users at other workstations cannot accidentally continue to work with the old
version and that you are not left with an old database after the update. However, with
this method you will have to take additional steps if you still wish to use the old version
of Image Capture.

Create copy and update original Here a copy of the existing database is created on the SQL
Server, after which the existing database is updated. The advantage of this method is
that users at other workstations cannot accidentally continue to work with the old ver‐
sion. However, with this method you will have to take additional steps if you still wish to
use the old version of ImageCapture. Also, the database copy will remain in existence af‐
ter the update and, if the new version works to your satisfaction, you will have to delete
the database copy manually.

To update the database, follow the steps below:

• Start the ImageCapture Manager.
• Youwill receive the notification that the existing database is not the correct version. Click

on OK to close this message.
• Go to File→Update Database. Youwill now see the screen as shown in Figure 9.3. Here,

proceed with the following steps:
1. Under Connection settings, enter the name of the SQL Server instance. Optionally,

the timeouts can be changed here.
2. Under Admin credentials, enter a user with sa permissions. These credentials will

only be used once, for the creation of the database.
3. Under Daily use credentials, enter a daily user that will from now on be used by

ImageCapture to access the database. If this user does not yet exist on the chosen
SQL Server instance, it will automatically be created.

4. Click on Retrieve databases to retrieve the list of ImageCapture databases.
5. ImageCapture will now automatically select the already linked database in the re‐

trieved list of databases. Leave this selection unchanged to update this database.
The corresponding database name will then automatically be entered.

6. Choose your preferred update method.
7. Click on OK to perform the update.

• When the database has been updated, a confirmation will be displayed. Hereafter you
can log in with the same credentials as used previously.
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Figure 9.3: Updating database
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Chapter 10

Client Service

Subjects in this chapter:
• Unattended processing.
• Client Service components.
• Distributing cores/licenses and sessions.
• Processing order of jobs and documents.

The Client Service processes documents and batches in ImageCapture unattended. The Client
Service only processes documents for active, licensed classes that are not in use in a Manager.
Within these classes, only licensed jobs are processed for which no user input is needed and
for which the chosen ImageCapture user is authorized.

10.1 Components
The Client Service consists of three different executables, see also Figure 10.1:

• ClientService.exe
• ClientServiceProcess.exe
• ClientServiceWorker.exe

10.1.1 Service
The Client Service executable is the only one that is a Windows service. It starts the Client
Service Process and ensures that it continues to run.

10.1.2 Process
The Process connects to the ImageCapture database and communicates with the License Ser‐
vice. In the Manager in Tools → Options → Machine the maximum number of cores that
may be used on that system can be specified. The Process tries to acquire that number of
cores/licenses from the License Service and launches a new Client Service Worker for each
acquired license. The License Service distributes the available licenses efficiently across all
connected systems and sends the actual number of licenses in the keep‐alive signal back to
the Process. Using this information, the Process scales the number of Workers up or down.
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Figure 10.1: Client Service components
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One systemcan run atmost 8Workers simultaneously, or atmost the number of reported cores
in that system. For a systemwith hyperthreading, Windows reports twice as many logical as
physical cores when hyperthreading is enabled in the BIOS. On such a systemwith two physical
cores (dual-core), 4Workers are allowed to run. However, this hardly improves performance
for configurations with a lot of processor‐intensive operations, like OCR text recognition. In
that case, a maximum of two physical cores should be configured in Tools → Options.

10.1.3 Worker
Each Worker is launched as a separate 32‐bit process and does the actual processing of docu‐
ments with a single core. Every Worker therefore has its own 1 GB of memory space.

A Worker runs with the goal to process documents through the entire process as efficiently as
possible. Globally speaking, already imported documents are made available for user input as
soon as possible and are then exported to the underlying applications as soon as possible. New
files will only be imported when all existing documents have been processed completely or are
waiting for user input. To achieve this, all jobs and documents are grouped and processed as
follows:

• Jobs and documents are divided into the following priority groups:
1. Web Importers.
2. Unattended jobs, except for groups 3 en 4 and documents with status Waiting or

Errored.
3. Import Jobs, except for group 1.
4. Web Service Jobs that synchronize all administrations.
5. Identical to group 2, but now including documents with statusWaiting or Errored.

• These groups are assembled over all classes to distribute the processing capacity evenly
over all classes.

• The groups are always processed in the same order.
• If a group has actually processed something, processing continues at group 1.
• Within a group, after one minute, only the current document is finished.
• Within groups 2 and 5, at most 5 documents are processed per job.
• Within groups 2 and 5, a document is processed by as much consecutive unattended

jobs as possible, without unlocking and reloading the document inbetween.

Individual documents are processed as follows:

• Documents with statusWaiting are only processed again after at least 5 minutes.
• Documents with status Errored are only processed again after at least 5 minutes as well.

Except in an Export Job if the option Erroneous documents retry timeout (hours) in Client
Service is configured with an aberrant interval in the Manager. For example, a longer
interval prevents documents frombeing sent to an external web services too oftenwhile
it will become Errored again anyway because of a validation error.

• One system always executes at most one Export Job at a time, regardless of the number
Workers that are running on that system. This limit is enforced because some exports
do not work correctly when used from multiple processes simultaneously. The conse‐
quence is that exports are not processed multi‐core.

• To prevent possibly increasingmemory usage, aWorker always stops itself automatically
every 12 hours, after which it is started again by the Process.
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10.2 Sessions
When the Windows service is stopped, it ensures that its Process and all its Workers are also
be stopped properly. A Worker also stops itself immediately when the process unexpectedly
isn’t running anymore. This can happen in case of connection problemswith the ImageCapture
database or License Service, or if the session is removed by an Admin user in Manager using
Tools → Session & Locks….. The Process also stops itself immediately when the Windows ser‐
vice is no longer running.

When opening a class in the Manager, all Client Service sessions that are using that class are
removed, so the Client Service does not need to be stoppedmanually when a class needs to be
modified. Each Process and Worker will then shutdown automatically because its session was
removed. The Client Service will then restart the Process, after which it will resume processing
documents in all classes that are not in use in the Manager. When the class is closed in the
Manager, the Client Service will resume processing that class in due time.

CHAPTER 10. CLIENT SERVICE 58



Part IV

Appendices

59



About this Document

This document is written in Markdown1 and converted with Pandoc2 and LaTeX3 to PDF4.

1http://daringfireball.net/projects/markdown: “Markdown allows you to write using an easy‐to‐read, easy‐
to‐write plain text format, then convert it to structurally valid XHTML.”

2http://johnmacfarlane.net/pandoc: “If you need to convert files from one markup format into another, pan‐
doc is your swiss‐army knife.”

3http://www.latex‐project.org: “LATEX is a high‐quality typesetting system; it includes features designed for the
production of technical and scientific documentation.”

4http://en.wikipedia.org/wiki/Portable_Document_Format: “PortableDocument Format (PDF) is a file format
used to present documents in a manner independent of application software, hardware and operating systems.”
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